Back to overview
Degraded

Website may be loading slowly for some users

Dec 23, 2024 at 2:50pm UTC
Affected services
Website

Resolved
Jan 2, 2025 at 9:02am UTC

Resolved | This incident has been resolved.

Updated
Dec 23, 2024 at 5:47pm UTC

Monitoring | A fix has been implemented and we are monitoring the results.

Updated
Dec 23, 2024 at 5:29pm UTC

Identified | The issue has been identified and a fix is being implemented.

Created
Dec 23, 2024 at 2:50pm UTC

Investigating | We are currently investigating this issue.